« Incorporating the NBII Thesaurus into Drupal | Main | Setting up the CAPTCHA Module in Drupal »

November 08, 2010

Patching the CCK Required by Role module

There's a bug in this module that causes it to fail when working with a date field. Basically, the bug keeps you from exempting a Role from completing required fields.

To fix:

1) Update to the dev version:
$ sudo drush dl cck_required_by_role-6.x-1.x-dev

2) Place patch file into the module directory. Patch available here.

3) Apply patch:
$ cd sites/all/modules/cck_required_by_role/
$ sudo patch -p0 < cck_required_by_role.module.patch

4) Check the results

Posted by kkwaiser at November 8, 2010 10:35 AM

Comments

Login to leave a comment. Create a new account.