Main | Hey - yo, World! »

May 31, 2005

Reanimating a dead 8.6 HD

[NOTE: This is not a knock on FWB Software or its products. I'm pretty sure the docs that came with the machine actually said "if you upgrade past Mac OS 8.1, don't run the included HD ToolKit." Naturally, I remembered this around the time of paragraph 3, below.]

Round 'bout 2001 I was still rockin' a SuperMac C600 [a Mac clone] with 128MB RAM and a 40 gig Maxtor hard drive, with MacOS 8.6. This was a few months after WorldCom figured out they were WorldCom and started hacking at their workforce as though it were on fire. I'd been trying to max the C6's blazing 240MHz processor power out and I had it running 8.6 TO THE LIMIT.

I don't exactly recall why, but I got sloppy and updated the HD device drivers with FWB HD ToolKit Personal Edition, which was on the Umax OS 8 install disc that came with the C6, rather than use Drive Setup. OS 8.5 and up hated -- HATED -- these drivers, and when the unit was powered on it immediately froze when trying to boot from the drive. When I would boot from other discs, like DiskWarrior, those would also freeze as soon as it tried to mount the hard drive.

With nothing to lose, I was ready to try some Chaos Manor type stuff. I downloaded an ISO at a friend's house and burned a LinuxPPC install disc. When I booted from this, amazingly, I was able to mount the drive, and in perldisk, LinuxPPC's graphical partitioning utility, the "FWB Device Drivers" was plainly visible. So I formatted it, figuring that this was the cause of the problem, and at worst I would lose all of my data, which was unmountable already anyway.

Then, I rebooted from my [dad's] AppleCare rescue CD, and the hard drive appeared on the desktop! I ran TechTool Pro on it, which took several hours and presented a clean bill of health [given the AppleCare disc, this might actually have been TechTool Deluxe]. Then I used Apple Drive Setup to update the drivers. After a restart, it booted from the drive, but the Finder crashed, so I booted again from the AppleCare CD and backed everything up to another Mac [I don't remember how exactly I managed to do this, what with the C600 not having FireWire -- maybe I put both macs on a hub and set up File Sharing].

I am certain that this is all archived somewhere, possibly on LowEndMac's SuperMacs list circa August 2001.

The moral is that if all else fails, maybe haul out a Linux CD and see if you can see the drive. And don't forget to break the rules! Just, you know, don't break any rules.

Posted by britainw at May 31, 2005 06:34 PM

Comments

Login to leave a comment. Create a new account.